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New Features in version 1.5

Amazon Lookup 
UPC Barcode Reader Support
Export Data to iPod 
HTML Templates
Improved Sorting Options
International Amazon Support
New Cover View

Purchase a license for DVD Database X and automatically 
receive a coupon code for $20 off a new USB UPC Barcode 
Scannner!  Regularly $79, it’s only $59 + S&H with the discount.  
This is a quality scanner at a great price, guaranteed to work with 
DVD Database X.  Enter DVD’s as fast as you can scan them!

Download and Installation

DVD Database X is distributed as a zipped archive.  Right-click the DVD Database X.zip 
file and select “Extract All” to bring uo the Extraction Wizard.  Extract to a new folder.  You 
can then move the unzipped DVD Database X folder to C:\Program Files. After you run 
the program for the first time, the DVD data folder must remain in the same folder as the 
application.

Adding Movies With A UPC Barcode Reader

If you have a barcode scanner and an active internet connection, you can use multiple 
movie feature to add your DVD’s quickly to DVD Database X.

Click File > Add Multiple Movies by UPC Code (or hit Command-Shift-N), and the 
Multiple Entry Screen will appear.  Scan the UPC codes into the UPC text field, one per 



line.  Most barcode scanners (including the Kanescan) will insert an Return character after a 
barcode, so you will not have to use the keyboard at all.

Once all the codes have been entered, click the Lookup UPC Codes button.  UPC codes 
found in the Amazon database will be displayed in the list.

Codes that are not found will be printed in blue, invalid codes will be printed in red.

Click the Add DVD’s In List button to add the DVD’s from the list into your database.

Most barcode scanners on the market should work just fine with DVD Database X, however 
the only officially supported model is the Kanescan CCD Barcode Scanner, available from 
http://www.kanecal.com.  Please contact the author of DVD Database X for instructions to 
receive $20 off the Kanescan Barcode Scanner - total price $59 + S&H.

Adding Movies Using Amazon

If you have an active internet connection, DVD Database X can perform a title or UPC 
search using the Amazon.com database.

From the menu, click Search > Amazon Lookup (or hit Command-A).  Type in the movie 
title, and click Amazon Lookup (or hit the Enter key).  DVD Database X will query the 
Amazon website.  Search results are returned in the list, or the database fields are 
automatically filled in if an exact match is found.  If more than one result is found, click the 
movie in the list to load the fields for each search result.

Click Add DVD to add the selected movie to your database.

If you have a movie already entered, and you’d like to look it up using Amazon, click the 
Search Menu > Amazon Lookup [Movie Name] (or hit Shift-Command-A).  The Amazon 
search screen will open, and DVD Database X will search the Amazon.com database for 
the selected movie title.  Click Update Selected DVD to update the DVD record with the 
info shown, according to the rules set in Merging Panel of Preferences.

If you select multiple movies, and click the Search Menu > Amazon Lookup X Selected 
Movies, all titles from your selected movies will be loaded into the combo box at the top of 
the Amazon Search Screen.  Select a movie title from the pull-down menu, and click 
Lookup to search Amazon for it.

Adding Movies Manually

Click the Add button on the main screen (or hit Command-N), and fill in the fields.

If you rarely use this screen, consider setting the Add button to bring up the IMDB screen.  
You can find this setting in Preferences > Behavior. 

Selecting Movies

To select a single movie, click on the appropriate row in the movie list on DVD Database 
X’s main screen.  

Hold down the Shift key while clicking to select all movie records between two points.



Hold down the Command key (Apple Key) while you click to select nonadjacent movies.

Adding Movies Using IMDB

If you have an active internet connection, DVD Database X can perform a title search using 
the IMDB website.

From the menu, click Search > IMDB Lookup (or hit Command-M).  Type in the movie title, 
and click Lookup (or hit the Enter key).  DVD Database X will query the IMDB website.  
Search results are returned in the list, or the database fields are automatically filled in if an 
exact match is found.  If more than one result is found, click the movie in the list to load the 
fields for each search result.

Click Add DVD to add the selected movie to your database.

If you have a movie already entered, and you’d like to look it up using IMDB.com, click the 
Search Menu > IMDB Lookup [Movie Name] (or hit Shift-Command-M).  The IMDB 
search screen will open, and DVD Database X will search the IMDB.com database for the 
selected movie title.Click Update Selected DVD to update the DVD record with the info 
shown, according to the rules set in Merging Panel of Preferences.

If you select multiple movies, and click the Search Menu > IMDB Lookup X Selected 
Movies, all titles from your selected movies will be loaded into the combo box at the top of 
the IMDB Search Screen.  Select a movie title from the pull-down menu, and click Lookup 
to search IMDB for it.

IMDB changes its website layout periodically, so I’ve externalized the html parsing routines 
for DVD Database X.  The file IMDB script.txt contains the REALbasic code that’s used 
to separate the IMDB fields.  When IMDB changes its website, I’ll post a new version of 
this script on my web server, and DVD Database X will download and install it automatically 
if the preference to do so is set.  This preference is on by default, but you may turn it off 
from Preferences > IMDB.  

IMDB is an independently operated website, and the author of DVD Database X cannot 
take responsibility for its content.

Editing Movies

Select a movie from the main screen, and click Edit.  Or, you may simply double-click a 
movie.  Edit the fields and click Save.

You can edit multiple movies by selecting them, and clicking the Edit button.  The Multiple 
Movie Edit screen will be displayed.  Any fields that are the same among your selected 
movies will be filled in.  To make a change to all selected movies, click the checkbox next to 
the appropriate field, and fill in the information.  Click Save or Cancel.

Searching Your Movies

You can search any field in your movie collection including user-defined fields.  From the 
menu, click Search > Search My Movies (or hit Command-S).  Pick the field you want to 



search and type in what you want to search for.  Searches are not case sensitive.

After a search, hit the Show All button to display your entire collection.

Adding Your Own Custom Fields

Click Edit > Database Fields (or hit Command-D), and the Custom Fields window will 
appear.

Type in a name for your new field in the Field Name text box, and click Add.  Your new 
field is instantly added to the database.  To delete a field, click its name in the list, and click 
the Delete button.  You’ll be asked to confirm the deletion.

Your custom fields can now be populated from the Edit Movie screen.  You can show and 
hide these fields using Display tab of the Preferences screen.

Showing and Hiding the Cover Graphics and Plot

From the menu, click View > Show Cover and Plot (or hit Command-Z).  The Movie and 
Plot drawer will slide out from the left side of the main screen, and display the cover art and 
plot for each movie clicked.

Click View > Hide Cover and Plot (or hit Command-Z again) to hide this feature.

DVD Database X will remember the drawer’s position and size when you quit the program.

Cover View and List View

In version 1.5.3, DVD Database X now has a new Cover View option, to view your DVD 
collection as a grid of DVD cover images.  Click View > Cover View to show all of your 
DVD covers.  Click View > List View to view as a list.

When in Cover View, use the slider at the bottom right of the main window to adjust the 
size of the cover images.

Printing Templates

New in version 1.4 is a custom WYSIWYG (What You See Is What You Get) layout tool 
for printing your movie records.  Click File > Print > Template Manager (Shift-Command-P) 
to show the Template Manager.

Select the Form to display the available templates for it.  The forms are Movie List 
Templates, DVD Label Templates, and DVD Jacket Templates.

Version 1.4 includes two built-in templates for each: Movie lists, DVD labels, and DVD 
jackets.  

Movie List Templates

Default List Template  - Use this template to produce a detailed listing of your 
movie info



Movie Title List - Use this to print a list of movie titles only

DVD Label Templates

Default Label Template - Prints a DVD label with Title, Year, Cover Image, and 
My Rating
Movie Title Label Template - Prints a DVD label with movie title only

DVD Jacket Templates

Default Jacket Template - Prints a DVD Jacket with detailed DVD info on the 
front, Plot on the back, and the movie title on the spine
Image Jacket Template - Prints a DVD Jacket with the cover image on the front, 
and the title on the spine 

Click the New button on the Template Manager window to create a new blank template.  
Click the Edit button (or double-click a template) to edit it.  Click the Delete button to delete 
a template that you’ve created - You cannot delete the built in templates.  Click the Close 
button to close the Template Manager window.

If you’ve created a new template, or you’re editing an existing template, you’ll use the 
Template Editor.  Drag a field from the Available Fields list into the layout window.  Position 
it where you want it to print.  Field Properties will be applied to newly added fields.  To edit 
the properties of a field or to delete it, Control-Click it, and select the appropriate choice 
from the contextual menu.

Click Save to save your template, and your new template will be available for printing the 
appropriate form.

Click Close to close the Template Editor window.

Printing a List of Your Movies

Click File > Print > Print List of X Displayed Movies (or hit Command-P).  Select the 
Template that you want to use to print.  Click the Print One Movie per Page checkbox for a 
separate page for each movie.  Click the Print button, and you will see the standard page 
setup and print dialogs for your printer.

If are displaying the results of a search, only the displayed movies will be printed.

DVD Database X will now order your listings in the same way they are ordered on the main 
screen.

Printing Information for a Selected Movie or Movies

Select a single movie or multiple movies on the main screen.  Select Print Info for [Movie 
Title] or Print Info for X Selected Movies (Command-Option-P).  Select the Template that 
you want to use to print.  Click the Print One Movie per Page checkbox for a separate 
page for each movie.  Click the Print button, and you will see the standard page setup and 
print dialogs for your printer.



Printing DVD Labels 

Select a movie or multiple movies from the main screen that you want to print a label for.  
Click File > Print > Print DVD Label (or hit Command-L).  Select the Template that you want 
to use to print for your label.  Click the Print button, and you will see the standard page 
setup and print dialogs for your printer.

The Horizontal Offset and Vertical Offset fields are used to adjust the position of the label 
printed on your label stock.  If the print is not correctly positioned on your label sheets, you 
need to make adjustments to these settings.  Each pixel is 1/72”.

Printing DVD Jacket Inserts

Select a movie or multiple movies from the main screen that you want to print a jacket for.  
Click File > Print > Print DVD Jacket (or hit Command-J).  Select the Template that you 
want to use to print for your jacket.  Click the Print button, and you will see the standard 
page setup and print dialogs for your printer.

Creating Web Pages From Your Database

Click File > Export > Web Pages > Table... (or hit Command-R) and the Export Movie 
Database to HTML dialog will be displayed. 

File Name will be proceeded by a page number, so if you keep the default, your pages 
will be named DVD Database X Movies_1.html, DVD Database X Movies_2.html, etc.

Rows and columns determine how your movies will be displayed on the web page.  This 
is a regular html table.  Depending upon how many rows and columns you set, the number 
of HTML pages will change.

Table Border Width is the width in pixels of the table border.  Set it to 0 (zero) for an 
invisible table.

The Include Movie Plot and Include Images check boxes are self-explanatory.  Your web 
pages will also include those fields in the order that are checked in the Preferences > 
Display tab.

Click the Browse button to save your web pages in a folder other than Documents.

Click File > Export > Web Pages > Templates... to use an html template to produce your 
web pages.  Four example templates are included.  Open up one of the text files located 
in DVD Data/HTML Templates, and see how they work.

Using the html templates, you can get your web pages to look exactly how you want, but 
you’ll need to learn a little html.  Just use an html comment containing only the name of the 
field, and DVD Database X will insert the field’s value in the template for every movie in 
your database.  For example, if you’d like the title in bold, use <b><!--Title--></b>.

DVD Database X will order your html output in the same way as the displayed order on the 
main screen.



Lending and Returning Movies

Select the movie or movies that you want to lend out.  Click the Loan button, and select 
your friend from the pull-down list, or enter a new name.   Click the Loan button.

In the preferences, you can check Show Address Book contacts when loaning movies on 
the Behavior tab.  When loaning movies, you’ll see the names of people in your Address 
Book.

When the movie has been returned, select it on the main screen, and hit the Return button.

The X Movies on Loan button will display a menu list of your loaned movies.  Click on them 
to jump to a loaned movie.

Friends and Formats

Delete friends (who have not returned your movies!) and video and audio formats by 
selecting Edit > Friends and Formats.  Select the appropriate table, the appropriate entry, 
and click delete.

Importing and Exporting

Click File > Export > Text File (or hit Command-F) and the Export Movie Database to Text 
File dialog will be displayed.

Your database will be exported as a tab-delimited text file including the fields in the order 
that you have checked in Preferences > Display.  Use the Include Movie Plot and Include 
Image File name check boxes to add those fields as well.

Click Export, and you’ll see a standard Save File dialog for your file.  The first line of the 
exported file will contain the tag <DVD Database X Key> followed by a tab-delimited list 
of the field names.  This line tells DVD Database X the names of the fields and their position 
in the exported file.

To import a tab-delimited text file, click File > Import... (or hit Command-I) and you’ll see a 
standard Open File Dialog.  Select the file that you want to import.

If the file does not contain a key (see above), DVD Database X will assume that the file is 
the same layout as was created by version 1.2.  Here is the layout that will be assumed:

Movie title
Genre
Year
Director
Video Aspect Ratio
Sound
Cast
Borrower
Borrowed Date
Path to VIDEO_TS Folder
Image file name (located in DVD data/images)
Plot



Runtime

If the file contains a key, you’ll see the Import File Preview dialog, which will show you how 
the file will be imported.  Custom fields will be added to the database if necessary.  Click 
Import or Cancel.  

iPod Export

You can easily create a folder of text files in iPod Notes format, that you can transfer to your 
iPod for browsing your DVD collection.  Click File > Export > iPod Format (Command-O), 
and select a folder to create the files in.  When completed, drag the entire folder to your 
Notes folder on your iPod.  Your DVD collection will be broken down alphabetically on your 
iPod.  Just select a letter of the alphabet to browse the movies that begin with that letter.

Playing Movies From DVD Database X

IMPORTANT - Any movie that you wish to play from DVD Database X cannot be 
encrypted.  You can use any of the available utilities to create a backup of a commercial 
DVD on your hard drive.

From the Add New Movie or Edit Movie screen, click the Browse button next to the Path to 
VIDEO_TS.VOB File text box.  Navigate to the unencrypted VIDEO_TS.VOB file, and 
click Open.  Click the Save button.

If you have done the above step, the Play button will appear when you click on the movie 
from the main screen.  Click it (or Command-Y), and the movie will play using your default 
DVD Player.

Adding Movie Trailers

From the Add New Movie or Edit Movie screen, click the Browse button next to the one of 
the Trailer fields.  Navigate to the movie trailer (usually, a .mov file, but it can be any format 
that your default player understands), and click Open.  Click the Save button.

If you have done the above step, one or more Movie trailer icons will appear on the 
bottom right corner of the main screen when you click on a movie.  Click one of these icons 
and the trailer will open and play in your default media player.

Preferences

Appearance
Here you can select the colors for highlighting your playable and loaned
movies.  The color key on the top of the main screen can also be hidden.

Web
Automatically check for new IMDB script file 

If this is set, DVD Database X will look on my web server for updates
for the IMDB script.  If IMDB changes their website, I’ll post a new
version of the script within a day or two.

Check for new version now
Checks for a new version of the IMDB script and installs it.



Amazon Locale
Change the Amazon site that DVD Database X searches

Behavior
Add Button brings up IMDB screen

If this is checked, the Add button will bring up the IMDB search screen.
If unchecked, the manual add screen will be shown.  You can still
access either screen from the keyboard shortcuts.

Alert before adding duplicate movie titles
Turn on this feature to be presented with an option to add or replace 
existing movie records

Move “A” from the beginning to the end of each DVD title
Move “The” from the beginning to the end of each DVD title

Both of these options will alter the DVD titles to help you sort your 
DVD’s more intelligently

Display
Drag and drop the individual fields to reorder them on the main window.
Check them to show, or uncheck them to hide their display on the main screen

Merging
Check the data source that you’d like to take precedence, when internet
seaches for the same DVD produce different results.

 
Program Removal

To remove DVD Database X from your PC, delete the DVD Database X folder that was 
extracted in the Installation step.

There is also a preference file located in C:\Documents and Settings\(User 
Name)\Application Data\DVD Database X Preferences that must be manually removed.

No DLL files are added or updated by DVD Database X.

I really appreciate all of your comments and suggestions!  I’m always looking into features to 
add to the next version of DVD Database X, so if you have any ideas, please let me 
know.

Change History

1.4 - 10/15/2004

Multiple Record Selections - Update, Delete, Loan, and Print Info for Multiple Movies
Multiple IMDB.com Lookups - Look up multiple movies with a single click
Custom Printing - Design your own Reports, DVD Labels and DVD Jackets by dragging 
and dropping your database fields into a WYSIWYG layout using the new Template 
Editor
Drag and Drop Support for Images Throughout the Program
Address Book Integration for Loaning Movies

1.3 - 7/19/2004

User-Defined Fields, MPAA and My Rating for rating your movies, Automatic Playing of 



Movie Trailers, and Export to HTML Functionality

1.2 - 6/21/2004

Automatic upgrading of IMDB html parsing routines, International character support, Custom 
highlighting of playable and loaned DVDs, Hide, show, reorder fields, Movie runtime from 
IMDB added, and Many interface tweaks and bug fixes.

1.1 - 6/7/2004

Maintenance release. Fixes plot summary and image retrieval from IMDB, and now allows 
users to add their own cover images.

1.0 - 5/22/2004

Initial public release.

Copyright 2005, Valencio Productions


